SDK-SecureChat Sample Linker error

0
After i did download the newest ChatSample with IOS-SDK and tried to build, I got the two following strange warnings and one linking error, which I don't know how to resolve.

ld: warning: directory not found for option '-L/Users/mikel/Desktop/C2Call-SDK-V1.1.0-B57/3rdpartylibs/required'
ld: warning: directory not found for option '-F/Users/mikel/Desktop/C2Call-SDK-V1.2.1-B70'

ld: library not found for -lAWSCore
clang: error: linker command failed with exit code 1 (use -v to see invocation)

Does anybody know how to fix it?
I didn't change anything of the sample code.. I am using Xcode 7.2 on El Capitan.

Best regards
Leon
Responses (2)
  • Accepted Answer

    Friday, February 12 2016, 11:33 AM - #Permalink
    0
    The C2Call-SDK will be added via CocoaPods to the project and also all dependent libraries.
    Before building the sample code, you need to run

    pod install

    in the sample code directory.
    Please see the Release-Notes and the Readme in the SampleCode for more information.

    Best regards,

    Michael
    The reply is currently minimized Show
  • Accepted Answer

    Saturday, February 13 2016, 04:59 PM - #Permalink
    0
    the AWSCore couldn't be found, which produced the linking error.
    My mistake was, that I opened the project instead of the workspace file. The AWSCore is part of pods.
    Afterwards I worked properly.
    The reply is currently minimized Show
Your Reply

About us

C2Call GmbH leads the way in introducing next generation mobile and browser-based calling solutions for the computing cloud. FriendCaller for iOS and Android are built using C2Call SDK, and demonstrate the unique capabilities to establish a peer-to-peer connection with any mobile platform and with any Internet browser without prerequisite software installations. With the new C2Call SDK, developers would now be able to integrate features alike FriendCaller in their existing or new apps on mobile.